First time user can't get into the app after paying subscription fee

Hi there,

I’m having trouble getting access to reveri after I paid the subscription fee for one year to start my 7 day free trial. The welcome email has a link that simply takes me to the “sign up” page again rather than to the actual app. What am I doing wrong?

I signed up on my laptop with an email address instead of the other options. The welcome email instructs me to scan a QR code with my phone camera to get access to the app on my phone, which I did, but again…it just takes me to the “sign up” and pay again page. :frowning:

Can someone at reveri community help me please? I’ve sent 2 email messages to the support desk with no response…

I’d really like to start using the app immediately.


Hi Gwendalea,

I’m not sure when you emailed the support desk, but what with it being the weekend and thanks giving in the US, that probably accounts for not having a response. Have you tried going to the app store directly to download? Whenever I’ve updated the app, I re-download; that seems to work as Google already knows I have the app.

I’m not explaining this very well… Give it a go. I hope it works for you.

Thanks for the reply Anita. I signed up with my email on my computer so when I scanned the QR code on my phone to upload the app to my phone after purchase, the systems asks me to buy the app again. :persevere: I don’t think my phone knows I have already paid even with that QR code from my confirmation on my computer.

Technology…… :sweat:

Damnit! At least it’s Monday, you should hear back from support today.

I hope you get things sorted soon. Ooh, have you checked your bank account to make sure the funds went through? I had a problem like that with my phone recently. Worth a go.

Good luck. You will get the app, and it’s worth it.

Sorry to hear something has slowed you down with getting this app because its really really good and i hope you love it as much as i do

Thanks for your help. I did hear back from support that my payment went through. They could see that on their end, so hopefully I’ll get access today. I didn’t realize it ONLY works on a phone. I don’t buy stuff on my phone so that’s how this got confusing.

Thanks again for your help!

1 Like

Thanks. I’ve wandered around in the community discussions while I wait for help from support so it hasn’t been a total loss. :smiling_face:

Hey everyone who has read this thread - I’m happy to report I got the glitch worked out and I’m now fully functional on the app. Yay! Did the hypnotizability test and discovered I’m a “poet” so looking forward to some good sleep and stress relief in the days to come…

Thanks to everyone who commented and the support staff who helped me solve my issue. <3

1 Like

Yay! So glad to hear you got your issue sorted out. All the best with the app, youre going to love it!

You are so sweet, thank you! :hugs:

hopping in on this thread - as i’m having similar:

Email sent to support 22hrs ago, I’m aware the weekend is coming… i don’t want to lose 2 days of free trial… and I’m aware they don’t work at the weekend.

I tried to set up an account via the android app, with an email address with suffix of .info (I’m aware some sites ignore this as its 4 characters)

  • I did not receive the login link
  • (at least 24hrs later) I tried again via the app, same email as above no luck
  • I went to the website, tried again - no link sent
  • I tried a slightly different email (on the website) with suffix of .xyz
  • Entered my bank details
  • the link was sent through - I opened it via the app and I’m still waiting for a link to be sent?

Can this be rectified, I would also like to ensure the 7 day trial only starts from when I am able to access the app.

also tried the uninstalling as mentioned in this thread and still no link sent…

Who do I nudge at support to get this actioned?

Sorry I haven’t gotten back to the community posts lately. For full context, Reveri is an early-stage startup and a very small team. We don’t have weekend coverage in support yet for that reason, but we do strive to respond to all emails within 1 business day, which I believe we always do, barring exceptional circumstances. We have it in our near term plans to allocate more resources to support so that we can address all urgent issues with more immediacy as well as respond to everything our community has to say – regardless of urgency – across every channel!

With that said, here is the response to anyone who may experience the same issue that Gwendalea described in the original post:
If you have signed up on our website, and then you log into the Reveri app, but it is telling you to pay again, you have signed in with the wrong credentials. All you need to do is visit the app menu, log out, and then log back in using the same login method and email address you used when signing up online. Your membership will immediately synchronize and you’ll have full access to all sessions.

We try to make this as clear as possible in our communications but we clearly need to do more here, and I’ve been reporting this to our engineering team so we can come up with easier pathways for you all. In an ideal world, you don’t have to follow a set of instructions, and using the app is just seamless and intuitive. That is what we are striving for, and we appreciate your patience as we are juggling a lot as a small team with lots to prove in order to survive.

THANK YOU to the community for helping one another in this forum, and for all that you do to help us improve Reveri!